Using Adobe Dreamweaver to
Maintain WWU Templated Web Sites
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1. Making a File System Connection for your Computer

On Windows

Windows allows users to easily create permanent connections to network shares (including those
that host Web sites). Please be sure that you have the network path to your share (usually
provided by Web Services), and that you have been given permissions to access the share.
To connect to a network share in Windows, follow these steps (remember that you must be
logged in to the computer as yourself for your permissions to be valid):
e Right-click on your “My Computer” icon from the desktop or start menu (or double click
and select Tools).
e Click on “Map Network Drive.”
e Select a drive letter (or keep the default one), and write it down so you’ll remember later.
e Paste in the network path in the “Folder” text box. Note this is usually \\ra\sharename
or \\racer.atus.wwu.edu\sharename where sharename is the folder name you have
been give for your site
e Make sure that the “rReconnect at logon” check box is checked.
e Click on “Finish”
This step only needs to be performed once on each machine that you wish to connect to a
specific network share. The share will only be available to your user account on that computer;
other users of the same computer will need to perform these same steps if they need to connect to
the share.

On a Mac

To connect to a network share on a Mac, follow these steps:
1. From the Finder program, click on “Go” and select “Connect to Server”. Or select the

Apple key g:g and K at the same time
2. Inthe address box, type in your samba share name
a. Forracer: smb://racer.atus.wwu.edu/sharename
Forra: smb://ra.cc.wwu.edu/sharename
c. for myweb: afp://wuf-xxxx-wuf.wwu.edu (where Xxxx is stul stu2 stu3 or userl user2
user3 — call the helpdesk to determine your server).
3. You may be asked to enter your username and password
Students: _username.students.wwu
b. Faculty: _username.users.wwu
4. You may be asked to select a sub-folder to connect to (make sure that your username and
password gives you access to the folder; Web Services can help with this).

o

o
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2. Introduction to the Dreamweaver Workspace
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1. Menu Bar - File, Edit, Insert, Modify and Text contain most of your commands to
change or save the content in area 3. View, Site, Window contain the things you need to
do to modify your working area. Note the area under the Menu Bar has another view of
frequently-used commands, although most of these can also be found in the menu bar, but
here they are grouped differently. Common and Text contain the most basic tools.

2. File and CSS Panels - These can be added or hidden using the Window menu item. The
Files view is particularly heavily used while creating and editing pages.

3. Web Pages / Content Editor - Note the tabs along the top. Every time you double-click
an item in the Files Panel it opens it in this panel and leaves the previously open
documents as tabs so you can go back and forth between multiple documents. You can
Cascade or Tile the files using the Windows item on the menu. Note the Code / Split /
Design buttons directly below the File tabs - this enables you to toggle between HTML
code and presentation view. Finally note that the Title edit box is also set in the area
directly beside the Code / Design view buttons.

4. Context-Sensitive Properties Panel - this area allows you to modify HTML attributes
and presents the attributes appropriate to the tag your curser is on in the Content Panel.
For images it shows image information, for text, text information, etc.
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3. Setting up Dreamweaver Defaults

Go to the Dreamweaver Menu at
the top of the application window
and select Edit > Preferences ,
then select General from the
Category list on the left of the
popup (see screen at right).

Select the choices show here to
adhere to WWU standards.

Categary

| General

| ccessibility

| 4P Elements

| Code Coloring

| Code Format

| Coda Hinks

| Code Rewriting
| Copy/Paste
1255 Styles
|File Compare
|File Types [ Editors
|Fonks

| Highlighting

Invisible Elements

| Layout Mode
| Wew Document
| Preview in Browser

Sike

| Status Bar

Yalidakar

General

Dacurnent options: Show \Welcome Screen

Editing options:

|:| Reopen documents on startup
Warn when opening read-only files

Update links when maving files: | Prompt Tae]

Show dialog when inserting objects

Enable double-byte inline input

Switch ko plain paragraph after heading

[ Allaws multiple consecutive spaces

lse «strong= and <em: in place of <b= and <iz
Use C55 instead of HTML tags

WWarn when placing editable regions within <p> ot -
Centering:  (3)Use =divtag () Use <center> ta
Maximum number of hiskory steps: | 50

Spelling dictionary: | English {American) W |

Next, select New Document from the
Category list. Make sure the Default
extension is set to “.shtml” as shown.
This enables your templates to use
included files such as navigation,
headers and footers.

Next select Preview in Browser from
the Category list. Verify that the
browsers you use are listed and that
the Preview using temporary file is
selected as shown at right.

Category

General
Accessibility
AP Elements
Code Coloring
Code Format
Code Hints
Code Rewriting
Copy/Paste
55 Styles

File Compare

LS = T - —

Fants
Highlighting

Layout Mode
Mew Document

Inwisible Elements

Preview in Browser

Mew Document

Default document: |HTML .
Default extension: | .shtml

Defaul: Document Type (DTD): | ¥HTML 1.0 Transitional w
Default encoding: | Unicode (UTF-8) |

File Types [ Editars

Unicode Mormalization Form:

[#]Use when opening existing files that don't specify an er

 {Canonical Decompoasition, Followed by 1| s

Site
% |Status Bar [include Unicode Signature (EOM)
Walidator
[#] Shaw Mew Dacument dialag bax on Cantral+M
Category Preview in Browser
| General
| Accessibility G E] E]
| &P Elemerts : Gl
Code Coloring %
| Firefoi
| Code Format
Fgovie IExplore  F12
Code Rewriting
| Copy/Paste
55 Styles
|File Compare
|File Types [ Editors
|Fonts
Highlighting
| Iwisible Elements Defauls: [#]Primary browser
Layout Mode
| New Document [[]5econdary browser
| Previews in Broveser
|Site: Cptions: Previews using kemporary File
| Status Bar
| Yalidatar Selecting this option will create a temporary copy For preview and
server debugging. To update the document directly please uncheck
this aption. Mote that deselecting this option does nat apply to
previewing %SLT, which always use a temporary file,
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4. Setting up a Site for Dreamweaver

If you set up your site properly you avoid many problems such as links that don’t work and
images that can’t be seen and other problems that result from Dreamweaver not understanding
how the browser and server will view your page.

From the Dreamweaver Menu select Site > New Site ... and choose the Advanced tab as shown
below. Then select Local Info from the Category window on the left side of the dialog.

a. Set up Local Info

Site Name:

This is a name you’ll
remember the site by - it
doesn’t matter to
dreamweaver what it is.

Local root folder:

is your working directory.
This is usually the mapped
drive you set up in the first
section.

Links relative to:

indicates how you want
Dreamweaver to edit your
links. For WWU servers use
""Site Root" so that your links
start with "/" indicating the
root folder of the site.

HTTP address:

Site Definition for web services

Basic | Adwanced

Category Local Info

Local Info
Remote Info
Testing Setver
Cloaking

Site name: | weh services

Design Hotes Local rook Folder: | g:\webservices) =
Site Map Layout
File: iew Columins Defaulk images folder: =
Contribute
;emplates Links relative ta: () Document (%) Sike rook

pry

HTTP address; | http:/fracer, atus.wwu, edufwebservices!

This address is used fFor site relative links, and For
the Link Checker to detect HTTP links that refer to
wour own site

Case-sensitive links: [+] Use case-sensitive link checking
Cache: [¥]Enable cache

The cache maintains file and asset information in
the site, This speeds up the Asset panel, link
managerent, and Site Map Features,

Use your real URL, up to the root folder and "/* but no file name.

Case-sensitive links:

On Ra and all UNIX machines the folder "docs" is different from "Docs" so it's important that
when Dreamweaver proof-reads your links it checks for case. However the best practice is to
use only lower case characters in directories and file names and then there will be no confusion.
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b. Remote Info

If you decide to do your editing locally (on racer or on your hard drive), and then upload to the
server (such as ra or myweb), use Dreamweaver's Remote Info dialog to define the server

location.
—

By using the mapped
drive you set up in
section 1 you can use
Dreamweaver to easily

Basic | Advanced

Category Femote Info
|Lacal Info

move your files to the
server after testing
them locally. First set
Access: to "Local /

|Remote Info

Tesking Server A L.':f':.'.a.l'!lwefm.':.'[l.q )
Cloaking

D Notas Remote Folder: | »ih

| Sike Map Lavyout

|File Yiew Columns Mainkain synichronization information

Network" and Remote

| Contribute
folder: to your mapped | Templates [ ] autematically upload files ta server on save
network drive. |opry [ ]Enable file check in and check out

If you set up your remote server this way, then when you select the up arrow on your files tool
panel in Dreamweaver (see screenshot right) it will send your updates to the server. Also note
that this same screenshot shows the "Local

B
i

i

View" pulldown. If "Remote View" is
selected you can look at the files on the

server. However, whichever view is visible, s | | Local view "
the blue up arrow (circled) is always used to | =
move the highlighted files UP to the server — _

ghilg | =3 site-aTUS redesian on Wallaby (N i

and the green down arrow is always used to
move the highlighted files DOWN to the
local site.

P = T TR B S
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5. Using Dreamweaver to Edit your site
Creating a New Page
From menu, select File > - g
New and see the d|alog at Sike: Template For Site "husdey™:
) e am ATUS WebSite full-content
right. Select Page From Blank Page & boteadt s
Template in the left & b sidebar
column. Select your @ Blark Terplate i eas bwa_colurn
sitename from the middle s eastpubs
column, and then the far EBD Page fiom Template | 22 MXeY
right column will list your ﬁ o eRelaRs
. o L T C

temp_late I_ayout choices. ﬂ-j el | B T [
(Avoid using the no-nav T [
choice if it is offered unless b newfaculty

H , Other - -
you are doing advanced 4% partsce [¥]Update page when template changes
popup applications.) a _policies

Next verify that the check box next to Update page when
Template Changes is checked, as shown, and then select the
Create button. An untitled page will appear in the workspace.

Modifying the Content

Note that template pages will have
areas outlined in blue and labeled with
blue tags. One of these areas is marked

Create ] [ Zancel

with a red circle at right. These
markers will not show up in the web

(@Culumn template

page but merely mark the editable
areas.

+ Top content here

Headers

The Page header is marked with a ]

purple circle at right. If you place your  |: iLeft content here
cursor on this header, the Properties ;

box at the bottom of the
workspace will indicate that
this is a Heading 1 (as shown at
right in the inset). Every page
must begin with a Heading 1

i ICantent_laf

v 1Content battam

Properties

rmat | Heading 1 v Style | —omt

Faonk | Werdana, arial ™ Size | 1.5

Cantent_tight
=

and this Title should match the

link that is used to get to the page. If the page heading is “Student Information”, the user would
expect to arrive at that page from link called Student Information or something similar.

If there is much text on the rest of the page you should also employ Heading 2, 3 and so on in
descending order. This outline format allows both visual and auditory scanning (for those people
using screen readers) of the page content and is very important for ease of use.
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Text Edits

Simply start typing in an editable area to add your text. Remember that for the web a paragraph
break is done with a carriage return which adds an empty line. Occasionally, such as typing an
address, you will need to add a “break” which starts the next line without the extra space — use
Control-Enter instead of Enter for a line break. For clean looking pages do not overuse this
feature.

Links

To create a =

link & @l | hiring. skl

S Link, | Rkkpe: vy, amazon, com w = =M = todo.sht

g re | O Bl 2
arget | | o P bl

word that you : S b 7T chbml

want to be

the link word then go to the Link area in the properties box to enter the link address. If you are
going to a link that is NOT on your site, such as the wwu home page, or amazon.com, enter the
entire address here and select Target _blank (see above). The Target=blank setting causes the
link page to open in a new browser window or tab. This is useful for off-site pages and for pdf
documents. Both of these situations take the user away from your navigation menu, so it is useful
to open these kinds of links in separate windows.

If you are going to a page on your site (a “local” link), then use the little flower
symbol to “point” to the file in the Local Files area. Click on the flower symbol,

then drag it to the files area until the correct file is highlighted. Then let go of
your mouse and the filename will appear in the Link address box. If you hover over a closed
folder, it will open and you can continue to browse your file structure in this way. Using this
method will ensure that you have the fully qualified path name so that your links will work
(assuming you have set up your site correctly as above). Remember that for going to a web page
within your site, leave the Target box empty.

Images
To add an image, first size it properly in
Photoshop or other image editing software. Then
save it in your website folder, preferably in a sub-
folder called images or something similar. Then i
Select Insert > Image from the menu and browse gL W(_est.wwu.edu/ S e

. p_web_images.shtml
to the image you want to use. )

Don’t know how to use Photoshop to
prepare your images? See this page on
the ATUS web site:

Then you will be prompted to add a textual description of the image (“Alternate Text”). This is a
requirement for the web — please provide a meaningful phrase that would describe the purpose of
the image when images are not available.

Page Title

The Title is set at the top of the workspace — see edit
box at right. Enter a title in here. This title will show up
when the page is Googled and it also appears in the top
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of the browser next to the name of the browser tool. This should be 3-10 words that succinctly
describe the page contents.

Saving

Select File > Save or File > Save As and browse to the correct folder and enter a filename for
this webpage. Please name the file using all lower case letters, NO spaces, and no special
characters — underscore or dash could be used if you really need to. SHORT, SIMPLE filenames
are best. Please don’t get elaborate — the filename must be unique for this folder, but it does not
have to completely describe the contents! Save that for the title. Short and sweet is much kinder
to the user who may want to type it in at some point or who may see it in print.

6. Testing
Spell Check
(Text, Check Spelling or Shift-F7) Self-explanatory. Use it frequently!
Validation —
Use the validation engine to fix any Drear| It @), | O [EL @0 B (5 CheckPage
HTML errors that have crept in. Once 350 400 450 500 S50 £00 £50
the tool runs it displays any error it =~ I aaiavm ~umw-

finds below the Properties Panel in
the Results panel. If you click on the items in the Results panel it takes you to the area where the
mistake was made.

Quick Preview

The little globe next to the Title box is for previewing your results. If the result doesn’t appear to
have its template, verify that the Edit, Preferences, Preview in Browser, Options is set on. This is
useful for quickly viewing in both Firefox and IE, but should not replace actually testing in the
browsers. The quick preview is not exactly like the external environment and cannot replace
actual testing once the file is live.
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